Cara Membatasi Aktivitas Download File dengan MikroTik


mikrotikKali ini saya akan mencoba sharing cara membatasi/limit aktifitas download file di mikrotik. Banyak dari kita mengeluh dengan perilaku user yang hobi download file besar atau yang aneh-aneh. Mungkin ini diperlukan jika dalam topologi jaringan mikrotik, misalnya dalam jaringan kantor, jaringan warnet, jaringan rtrw net atau ISP yang menjual koneksi internet Up To atau tidak dedicated 1:1. Kita akan direpotkan oleh satu user yang berprilaku tukang download dan menghabisi jatah bandwidth user lain, terlebih jika yang bersangkutan menggunakan aplikasi download manager.

Perilaku user ini akan mencuri jatah bandwidth user yang lainnya yang akan menyebabkan user tersebut komplain kepada kitas sebagai admin karena koneksinya menjadi lambat. Sebagai admin, kita juga akan repot dan sulit untuk mendeteksi user mana yang telah mencuri bandwidth tersebut. Untuk hal tersebut, maka penggunaan limit download menggunakan mikrotik menjadi satu tindakan yang akan mengantisipasi permasalahan tersebut di atas.

.

Cara Setting Limit Download File Dengan L7 Filtering

Disini bagian ini kita pakai tehnik L7 Filtering untuk limit download file sesuai ektensi file yang Anda ditentukan, bisa untuk limit bandwidth download file exe, rar, zip, iso dan lain-lain.

Pertama, kita buat filtering regex content L7, tentukan string yang akan kita cari.

add name=”Extension \” .mp4 \”” regexp=”^.*get.+\\.mp4.*\$”

add name=”Extension \” .rar\”” regexp=”^.*get.+\\.rar.*\$”

add name=”Extension \” .zip\”” regexp=”^.*get.+\\.zip.*\$”

1
2
3
4
5
/ip firewall layer7-protocol
add name=”Extension \” .exe \”” regexp=”^.*get.+\\.exe.*\$
add name=”Extension \” .mp4 \”” regexp=”^.*get.+\\.mp4.*\$
add name=”Extension \” .rar\”” regexp=”^.*get.+\\.rar.*\$
add name=”Extension \” .zip\”” regexp=”^.*get.+\\.zip.*\$

dw l701 Cara Membatasi Aktifitas Download File Di MikroTik

Contoh di sini saya akan menggunakan string atau ekstensi file download hanya untuk file yang berekstensi exe, mp4, rar, dan zip. Anda bisa tambahkan sesuai kebutuhan.

Kedua, kita menandakan/mangle koneksi user berdasarkan regex L7 yang sebelumnya di buat untuk di proses lebih lanjut di queue bandwidth management mikrotik

Di WinBox akan terlihat seperti ini :
habibahmadpurba.wordpress2

.

Cara Setting Memisahkan Bandwidth Browsing dan Download

Di langkah ini saya anggap juga seperti cara setting memisahkan kecepatan bandwidth untuk browsing dan kecepatan untuk download file.

Ketiga, kita buat bandwidth managementnya si simple queue

Di setting simple queue diatas saya contohkan untuk memisahkan kecepatan untuk browsing dan untuk download file :

  • Aktifitas Browsing : Kecepatan Download 1Mbps & Kecepatan Upload 128Kbps
  • Aktifitas Download File : Kecepatan Download 128Kbps & Kecepatan Upload 128Kbps

Keempat, kita test apakah setting memisahkan kecepatan browsing dan download berjalan dengan baik :
habibahmadpurba.wordpress

.

Di gambar diatas, terlihat saat saya download file berekstensi .zip ter limit kecepatannya. Sesuai kecepatan yang saya setting di simple queue mikrotik. Terlihat juga walaupun user pakai internet download manager (IDM) ikut ter limit kecepatannya. Atau jika anda tidak mengijinkan user menggunakan aplikasi IDM (internet download manager) di jaringan anda, anda bisa coba teknik berikut.
.

Cara Drop Koneksi Download IDM (Internet Download Manager) pada Mikrotik

Anda bisa menambahkan rules di firewall mikrotik seperti ini, tetap menggunakan layer-7 filtering yang sebelumnya kita buat :

Firewall tersebut membuat jika ada yang download file menggunakan IDM, akan di drop oleh mikrotik. Karena IDM menggunakan koneksi lebih dari 1, maka firewall tersebut akan drop IDM jika menggunakan 4 koneksi lebih dalam 1 file download (lihat connection-limit=4,32). Script diatas diperhatikan “in-interface” sesuaikan port ether lokal Anda.

Mungkin ada beberapa teknik lainnya seperti memakai connection-byte, tapi sejauh ini melimit kecepatan download file di mikrotik lebih efektif menggunakan L7 Filtering, tapi membebani load router anda (jadi berat). Ada juga jika anda menggunakan proxy server bisa menggunakan “Delay-Pool” di squid untuk membatasi kecepatan download file.
.

Demikian pembahasan tentang Cara Membatasi Aktivitas Download File dengan MikroTik. Mudah-mudahan bermanfaat dan terima kasih.

 

Referensi:
http://adamonline.web.id

Posted on 10/06/2013, in Mikrotik, Tutorial and tagged , , , , . Bookmark the permalink. 5 Comments.

  1. I am really grateful to the owner of this site who has shared this
    impressive post at at this time.

  2. It’s in point of fact a great and helpful piece of information. I am happy that you simply shared this helpful information with us.

    Please keep us up to date like this. Thanks for sharing.

  3. Great beat ! I would like to apprentice whilst you amend your site, how could
    i subscribe for a blog website? The account aided me
    a appropriate deal. I were tiny bit familiar of this your broadcast
    offered vivid transparent idea

  4. Hello every one, here every one is sharing such knowledge, therefore it’s nice
    to read this blog, and I used to visit this blog every day.

  5. Hi mates, how is all, and what you want to say concerning this post, in my view its truly awesome for me.

Berikan Komentar Anda

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: